// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)PASSWORD\((?i)secret_?(?i)key\:["|'|`]?["|'|`]?\)"#).unwrap();
let string = "# Match this, double quotes included
PASSWORD(secret_key:\"\")
# Match this, single quotes included
PASSWORD(secret_key:'')
# Match this, back quote included
PASSWORD(SECRETKEY:``)
# Match this, no quotes included
PASSWORD(SECRETKEY:)
# No match, arrow brakets not included in pattern
PASSWORD(secretkey:<>)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}