# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(\S)/.\n\1/gm;t' <<< "Ex1. `This is a random sentence.1,7,9 This is a sentence followed by it.`
Ex2. I love football.1,7,24`I also like cricket.
Ex3. ESD for undifferentiated cancers.[1][7]`Cancers can be treatable."