use strict;
my $str = 'Ex1. `This is a random sentence.1,7,9 This is a sentence followed by it.`
Ex2. I love football.1,7,24`I also like cricket.
Ex3. ESD for undifferentiated cancers.[1][7]`Cancers can be treatable.';
my $regex = qr/\.(\S)/mp;
my $subst = '.\\n\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";