const regex = new RegExp('\\.(\\S)', 'gm')
const str = `Ex1. \`This is a random sentence.1,7,9 This is a sentence followed by it.\`
Ex2. I love football.1,7,24\`I also like cricket.
Ex3. ESD for undifferentiated cancers.[1][7]\`Cancers can be treatable.`;
const subst = `.\n\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);