package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.(\S)`)
var str = `Ex1. \`This is a random sentence.1,7,9 This is a sentence followed by it.\`
Ex2. I love football.1,7,24\`I also like cricket.
Ex3. ESD for undifferentiated cancers.[1][7]\`Cancers can be treatable.`
var substitution = ".\n\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}