# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.(\S)"
test_str = ("Ex1. `This is a random sentence.1,7,9 This is a sentence followed by it.`\n"
"Ex2. I love football.1,7,24`I also like cricket.\n\n"
"Ex3. ESD for undifferentiated cancers.[1][7]`Cancers can be treatable.")
subst = ".\\n\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.