#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.(\S)"
Local $sString = "Ex1. `This is a random sentence.1,7,9 This is a sentence followed by it.`" & @CRLF & _
"Ex2. I love football.1,7,24`I also like cricket." & @CRLF & _
"" & @CRLF & _
"Ex3. ESD for undifferentiated cancers.[1][7]`Cancers can be treatable."
Local $sSubst = ".\n\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)