using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(\S)";
string substitution = @".\n\1";
string input = @"Ex1. `This is a random sentence.1,7,9 This is a sentence followed by it.`
Ex2. I love football.1,7,24`I also like cricket.
Ex3. ESD for undifferentiated cancers.[1][7]`Cancers can be treatable.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}