# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:FOO|BAR|BA|IO)\b(?=\s(?:FOO|BAR|BA|IO)\b|$)//gm;t' <<< "Lorem ipsum dolor FOO IO BAR BA
LoremFOO ipBAsum IO dolor FOO"