import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:FOO|BAR|BA|IO)\\b(?=\\s(?:FOO|BAR|BA|IO)\\b|$)";
final String string = "Lorem ipsum dolor FOO IO BAR BA\n"
+ "LoremFOO ipBAsum IO dolor FOO";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}