use strict;
my $str = 'Lorem ipsum dolor FOO IO BAR BA
LoremFOO ipBAsum IO dolor FOO';
my $regex = qr/\b(?:FOO|BAR|BA|IO)\b(?=\s(?:FOO|BAR|BA|IO)\b|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";