re = /\b(?:FOO|BAR|BA|IO)\b(?=\s(?:FOO|BAR|BA|IO)\b|$)/m
str = 'Lorem ipsum dolor FOO IO BAR BA
LoremFOO ipBAsum IO dolor FOO'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result