using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:FOO|BAR|BA|IO)\b(?=\s(?:FOO|BAR|BA|IO)\b|$)";
string substitution = @"";
string input = @"Lorem ipsum dolor FOO IO BAR BA
LoremFOO ipBAsum IO dolor FOO";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}