$re = '/\b(?:FOO|BAR|BA|IO)\b(?=\s(?:FOO|BAR|BA|IO)\b|$)/m';
$str = 'Lorem ipsum dolor FOO IO BAR BA
LoremFOO ipBAsum IO dolor FOO';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;