const regex = /\b(?:FOO|BAR|BA|IO)\b(?=\s(?:FOO|BAR|BA|IO)\b|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:FOO|BAR|BA|IO)\\b(?=\\s(?:FOO|BAR|BA|IO)\\b|$)', 'gm')
const str = `Lorem ipsum dolor FOO IO BAR BA
LoremFOO ipBAsum IO dolor FOO`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);