import Foundation
let pattern = #"\b(?:FOO|BAR|BA|IO)\b(?=\s(?:FOO|BAR|BA|IO)\b|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lorem ipsum dolor FOO IO BAR BA
LoremFOO ipBAsum IO dolor FOO
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)