# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\w)\S*?(\S@)(\S)\S*.(\S\.\S*)\b/$1****$2$3****$4/;t' <<< "anexample@gmail.com"