using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w)\S*?(\S@)(\S)\S*.(\S\.\S*)\b";
string substitution = @"$1****$2$3****$4";
string input = @"anexample@gmail.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}