const regex = /\b(\w)\S*?(\S@)(\S)\S*.(\S\.\S*)\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w)\\S*?(\\S@)(\\S)\\S*.(\\S\\.\\S*)\\b', '')
const str = `anexample@gmail.com`;
const subst = `$1****$2$3****$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);