// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(\w)\S*?(\S@)(\S)\S*.(\S\.\S*)\b").unwrap();
let string = "anexample@gmail.com";
let substitution = "$1****$2$3****$4";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}