re = /\b(\w)\S*?(\S@)(\S)\S*.(\S\.\S*)\b/
str = 'anexample@gmail.com'
subst = '$1****$2$3****$4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result