$re = '/\b(\w)\S*?(\S@)(\S)\S*.(\S\.\S*)\b/';
$str = 'anexample@gmail.com';
$subst = "$1****$2$3****$4";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;