# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+\.\w+\.)(\w)(\w+)/$1get\U$2\E$3()/gm;t' <<< "registerForm.main.myApplicant = value"