use strict;
my $str = 'registerForm.main.myApplicant = value';
my $regex = qr/(\w+\.\w+\.)(\w)(\w+)/mp;
my $subst = '$1get\\U$2\\E$3()';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";