re = /(\w+\.\w+\.)(\w)(\w+)/m
str = 'registerForm.main.myApplicant = value'
subst = '$1get\\U$2\\E$3()'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result