$re = '/(\w+\.\w+\.)(\w)(\w+)/m';
$str = 'registerForm.main.myApplicant = value';
$subst = "$1get\U$2\E$3()";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;