import Foundation
let pattern = #"(\w+\.\w+\.)(\w)(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"registerForm.main.myApplicant = value"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1get\U$2\E$3()"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)