const regex = /(\w+\.\w+\.)(\w)(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+\\.\\w+\\.)(\\w)(\\w+)', 'gm')
const str = `registerForm.main.myApplicant = value`;
const subst = `$1get\U$2\E$3()`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);