// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+\.\w+\.)(\w)(\w+)").unwrap();
let string = "registerForm.main.myApplicant = value";
let substitution = "$1get\\U$2\\E$3()";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}