# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a href="(?!мой сайт).+">(.+)<\/a>)/<b>$2<b>/gu;t' <<< "<a href=\"мой сайт/contacts\">сcылка на мой сайт</a>.
И ссылки вида <a href=\"не мой сайт\">Чужой</a>.
Так вот необходимо ссылки <a href=\"не мой сайт\">Чужой</a>, заменить например на <b>Чужой</b>. Учитывая, что
"