$re = '@(<a href="(?!мой сайт).+">(.+)</a>)@u';
$str = '<a href="мой сайт/contacts">сcылка на мой сайт</a>.
И ссылки вида <a href="не мой сайт">Чужой</a>.
Так вот необходимо ссылки <a href="не мой сайт">Чужой</a>, заменить например на <b>Чужой</b>. Учитывая, что
';
$subst = "<b>$2<b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;