re = /(<a href="(?!мой сайт).+">(.+)<\/a>)/
str = '<a href="мой сайт/contacts">сcылка на мой сайт</a>.
И ссылки вида <a href="не мой сайт">Чужой</a>.
Так вот необходимо ссылки <a href="не мой сайт">Чужой</a>, заменить например на <b>Чужой</b>. Учитывая, что
'
subst = '<b>$2<b>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result