using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a href=""(?!мой сайт).+"">(.+)</a>)";
string substitution = @"<b>$2<b>";
string input = @"<a href=""мой сайт/contacts"">сcылка на мой сайт</a>.
И ссылки вида <a href=""не мой сайт"">Чужой</a>.
Так вот необходимо ссылки <a href=""не мой сайт"">Чужой</a>, заменить например на <b>Чужой</b>. Учитывая, что
";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}