# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<a href=\"(?!мой сайт).+\">(.+)</a>)"
test_str = ("<a href=\"мой сайт/contacts\">сcылка на мой сайт</a>.\n"
"И ссылки вида <a href=\"не мой сайт\">Чужой</a>.\n\n"
"Так вот необходимо ссылки <a href=\"не мой сайт\">Чужой</a>, заменить например на <b>Чужой</b>. Учитывая, что \n\n")
subst = "<b>$2<b>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.