#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(<a href="(?!мой сайт).+">(.+)</a>)"
Local $sString = "<a href="мой сайт/contacts">сcылка на мой сайт</a>." & @CRLF & _
"И ссылки вида <a href="не мой сайт">Чужой</a>." & @CRLF & _
"" & @CRLF & _
"Так вот необходимо ссылки <a href="не мой сайт">Чужой</a>, заменить например на <b>Чужой</b>. Учитывая, что " & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "<b>$2<b>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)