use strict;
my $str = '<a href="мой сайт/contacts">сcылка на мой сайт</a>.
И ссылки вида <a href="не мой сайт">Чужой</a>.
Так вот необходимо ссылки <a href="не мой сайт">Чужой</a>, заменить например на <b>Чужой</b>. Учитывая, что
';
my $regex = qr@(<a href="(?!мой сайт).+">(.+)</a>)@up;
my $subst = '<b>$2<b>';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";