const regex = new RegExp('(<a href="(?!мой сайт).+">(.+)</a>)', 'gu')
const str = `<a href="мой сайт/contacts">сcылка на мой сайт</a>.
И ссылки вида <a href="не мой сайт">Чужой</a>.
Так вот необходимо ссылки <a href="не мой сайт">Чужой</a>, заменить например на <b>Чужой</b>. Учитывая, что
`;
const subst = `<b>$2<b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);