#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:.*\r?\n){2}.*random data.*"
Local $sString = "Line 1" & @CRLF & _
"Line 2" & @CRLF & _
"Line 1 with random data." & @CRLF & _
"Line 4" & @CRLF & _
"Line 5" & @CRLF & _
"Line 2 with random data." & @CRLF & _
"Line 7" & @CRLF & _
"Line 8" & @CRLF & _
"Line 9" & @CRLF & _
"Line 10" & @CRLF & _
"Line with random data.Line with random data."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")