import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.*\\r?\\n){2}.*random data.*";
final String string = "Line 1\n"
+ "Line 2\n"
+ "Line 1 with random data.\n"
+ "Line 4\n"
+ "Line 5\n"
+ "Line 2 with random data.\n"
+ "Line 7\n"
+ "Line 8\n"
+ "Line 9\n"
+ "Line 10\n"
+ "Line with random data.Line with random data.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}