using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.*\r?\n){2}.*random data.*";
string input = @"Line 1
Line 2
Line 1 with random data.
Line 4
Line 5
Line 2 with random data.
Line 7
Line 8
Line 9
Line 10
Line with random data.Line with random data.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}