re = /(?:.*\r?\n){2}.*random data.*/
str = 'Line 1
Line 2
Line 1 with random data.
Line 4
Line 5
Line 2 with random data.
Line 7
Line 8
Line 9
Line 10
Line with random data.Line with random data.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end