// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:.*\r?\n){2}.*random data.*").unwrap();
let string = "Line 1
Line 2
Line 1 with random data.
Line 4
Line 5
Line 2 with random data.
Line 7
Line 8
Line 9
Line 10
Line with random data.Line with random data.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}