import Foundation
let pattern = #"(?:.*\r?\n){2}.*random data.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Line 1
Line 2
Line 1 with random data.
Line 4
Line 5
Line 2 with random data.
Line 7
Line 8
Line 9
Line 10
Line with random data.Line with random data.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)