const regex = new RegExp('(?:.*\\r?\\n){2}.*random data.*', 'g')
const str = `Line 1
Line 2
Line 1 with random data.
Line 4
Line 5
Line 2 with random data.
Line 7
Line 8
Line 9
Line 10
Line with random data.Line with random data.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}