#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((CREATE.*my_table.*\n)|(\s+.*tinyint.*\n)|(\s+.*(?!tinyint)\n))"
Local $sString = "CREATE TABLE `my_table` (" & @CRLF & _
" `id` bigint(20) NOT NULL," & @CRLF & _
" `id2` bigint(27) NULL," & @CRLF & _
" `REVTYPE` tinyint(4) DEFAULT NULL," & @CRLF & _
" `REVTYPE2` bigint(52) blahblah," & @CRLF & _
" `REVTYPE` tinyint(7) stuff" & @CRLF & _
" `some_other_column` varchar(255)" & @CRLF & _
");"
Local $sSubst = "$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)