# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((CREATE.*my_table.*\n)|(\s+.*tinyint.*\n)|(\s+.*(?!tinyint)\n))"
test_str = ("CREATE TABLE `my_table` (\n"
" `id` bigint(20) NOT NULL,\n"
" `id2` bigint(27) NULL,\n"
" `REVTYPE` tinyint(4) DEFAULT NULL,\n"
" `REVTYPE2` bigint(52) blahblah,\n"
" `REVTYPE` tinyint(7) stuff\n"
" `some_other_column` varchar(255)\n"
");")
subst = "$2$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.