use strict;
my $str = 'CREATE TABLE `my_table` (
`id` bigint(20) NOT NULL,
`id2` bigint(27) NULL,
`REVTYPE` tinyint(4) DEFAULT NULL,
`REVTYPE2` bigint(52) blahblah,
`REVTYPE` tinyint(7) stuff
`some_other_column` varchar(255)
);';
my $regex = qr/((CREATE.*my_table.*\n)|(\s+.*tinyint.*\n)|(\s+.*(?!tinyint)\n))/p;
my $subst = '$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";