import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((CREATE.*my_table.*\\n)|(\\s+.*tinyint.*\\n)|(\\s+.*(?!tinyint)\\n))";
final String string = "CREATE TABLE `my_table` (\n"
+ " `id` bigint(20) NOT NULL,\n"
+ " `id2` bigint(27) NULL,\n"
+ " `REVTYPE` tinyint(4) DEFAULT NULL,\n"
+ " `REVTYPE2` bigint(52) blahblah,\n"
+ " `REVTYPE` tinyint(7) stuff\n"
+ " `some_other_column` varchar(255)\n"
+ ");";
final String subst = "$2$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}