using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((CREATE.*my_table.*\n)|(\s+.*tinyint.*\n)|(\s+.*(?!tinyint)\n))";
string substitution = @"$2$3";
string input = @"CREATE TABLE `my_table` (
`id` bigint(20) NOT NULL,
`id2` bigint(27) NULL,
`REVTYPE` tinyint(4) DEFAULT NULL,
`REVTYPE2` bigint(52) blahblah,
`REVTYPE` tinyint(7) stuff
`some_other_column` varchar(255)
);";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}