import Foundation
let pattern = #"((CREATE.*my_table.*\n)|(\s+.*tinyint.*\n)|(\s+.*(?!tinyint)\n))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
CREATE TABLE `my_table` (
`id` bigint(20) NOT NULL,
`id2` bigint(27) NULL,
`REVTYPE` tinyint(4) DEFAULT NULL,
`REVTYPE2` bigint(52) blahblah,
`REVTYPE` tinyint(7) stuff
`some_other_column` varchar(255)
);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)